Scrapy安装错误:error Microsoft Visual C++ 10.0 is required.

  • A+
所属分类:数据分析

在安装Scrapy框架时,常常会遇到不经意的错误,以下是作为新手的我遇到的错误,然后在网上找到了解决方案,希望能够解决遇到同样Scrapy安装问题的同学:

我的电脑是:win10   64位python3.6;以此为例;

 

使用pip install scrapy安装scrapy的时候出现错误:

rror: Microsoft Visual C++ 10.0 is required. Get it with "Microsoft Visual C++Build Tools": http://landinghub.visualstdio.com/visual-cpp-build-tools;

Scrapy安装错误截图如下:
Scrapy安装错误:error Microsoft Visual C++ 10.0 is required.

 

安装了Microsoft Visual C++ 10.0  已然是错误:

 

Scrapy安装错误:error Microsoft Visual C++ 10.0 is required.解决方案:

一,从http://www.lfd.uci.edu/~gohlke/pythonlibs/下载scrapy的两个依赖库lxml和twisted

二,分别安装:

  • pip install Twisted-16.4.1-cp34-cp36m-win_amd64.whl
  • pip install lxml-3.6.4-cp34-cp36m-win_amd64.whl

注意:依赖库的下载,根据自己的电脑和Python版本;

三,最后安装:scrapy:pip install scrapy;成功!

tangtang

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: